Wtyczka WCAG 2.1 WordPress - narzędzie które nie zapewnia dostępności cyfrowej

  • 19.02.2021, 20:01
  • art.sponsorowany
Wtyczka WCAG 2.1 WordPress - narzędzie które nie zapewnia dostępności cyfrowej
W roku 2016 Parlament Europejski uchwalił dyrektywę 2016/2102, która te zalecenia zamieniała w obowiązek. W roku 2018 rozszerzono wytyczne dostępności stron, rozszerzając je między innymi o aplikacje dostępne na urządzenia mobilne. Dyrektywa 2016/2102 oraz wytyczne WCAG 2.1 były podstawą do uchwalenia przez Sejm Ustawy o Dostępności Cyfrowej Stron Internetowych oraz Aplikacji Mobilnych Podmiotów Publicznych. Według zapisów tej ustawy, każdy podmiot publiczny posiadający, tworzący lub administrujący stroną internetową, musi ją dostosować by była ona zgodna z wytycznymi WCAG 2.1, Czy wtyczka WCAG 2.1 WordPress jest w stanie zapewnić taki standard?
 

Wtyczka WCAG 2.1 WordPress nie zapewnia standardu!

Obowiązująca od maja 2019 roku ustawa o dostępności stron internetowych nakłada na podmioty publiczne nie tylko dostosowanie swoich stron i aplikacji mobilnych do obowiązujących standardów WCAG 2.1, ale również w artykule 8 pkt 4, nakłada na nich obowiązek umieszczania na swoich stronach deklaracji dostępności strony internetowej lub aplikacji mobilnej. Ta deklaracja zgodności musi mieć formę cyfrową. Jednocześnie ustawodawca w art. 12 pkt 7 Ustawy, nałożył na Ministra Cyfryzacji obowiązek do umieszczenia na stronach Ministerstwa warunków technicznych oraz strukturę dokumentu elektronicznego deklaracji dostępności. Jednocześnie na Ministra Cyfryzacji nałożono obowiązek kontroli zgodności deklaracji ze stanem faktycznym. Wtyczka WCAG 2.1 WordPress tylko z pozoru jest narzędziem służącym do zapewnienia dostępności cyfrowej.

wtyczka-wcag-21-wordpress.jpg

Wtyczka WCAG 2.1 Wordpress nie zapewnia standardu WCAG

Wordpress to system oparty na języku PHP. To środowisko służące do tworzenia oraz zarządzania treścią między innymi blogów, stron internetowych. Jest to system darmowy i bardzo prosty w obsłudze. W systemie tym tworzona jest większość stron internetowych, jednocześnie  nie można zapominać, że jest to platforma, która posiada miliony rozwiązań, które można wykorzystać praktycznie dla każdego podmiotu. Środowisko systemu WordPress pozwala na stworzenie stron internetowych, które są dostępne dla osób niepełnosprawnych na poziomie wytycznych WCAG 2.1 poziom AA, jednak takiego standardu nie da się osiągnąć za pomocą instalacji wtyczki. Warto pamiętać, że WCAG na poziomie AA obejmuje aż 50 różnych kryteriów. Nie da się ich spełnić za pomocą kilku kliknięć. To zadanie należy powierzyć specjaliście. Na szczęście każdy podmiot, nie tylko publiczny, który będzie tworzyć strony internetowe oparte na systemie WordPress, będzie mógł dostosować stronę, aby ułatwić korzystanie z tej strony osobom niepełnosprawnym. Jednak jest to możliwe wyłącznie dzięki współpracy z doświadczonym specjalistą.

Wtyczka WCAG 2.1 WordPress bardziej szkodzi niż pomaga

Przeciwdziałanie wykluczeniu cyfrowemu dla osób niepełnosprawnych od kilkunastu lat stało się priorytetem. Żyjemy w społeczeństwie skomputeryzowanym, które chętnie sięga po możliwości jakie dają strony internetowe, czy też aplikacje n urządzeniach mobilnych. Do wirtualnego świata przenoszą się nie tylko sklepy, gazety, czy telewizja i radio, ale również urzędy, które oferują swoje usługi online. Na początku funkcjonowania stron internetowych panował swoisty chaos. Każdy twórca strony internetowej działał „po swojemu” przez co często strony internetowe mogły być wyświetlane tylko na określonych przeglądarkach. Pod koniec ubiegłego stulecia konsorcjum złożone z największych przedsiębiorców związanych z branżą komputerową oraz internetem opracowali zalecenia do takiego tworzenia stron internetowych, by były one widoczne dla jak największej grupy odbiorców. Zalecenia te zgormadzone zostały zgromadzone w dokumencie Wytyczne Dostępności Stron Internetowych WCAG. W roku 2008 w wyniku prac pod wpływem rozwoju technologicznego, opracowano nową wersję tego dokumentu w wersji 2.0, w którym zobligowano podmioty publiczne do dostosowania takich rozwiązań, by strony internetowe były dostępne dla osób niepełnosprawnych. Jednak były to jedynie zalecenia, które dopiero po kilku latach stały się podstawą do stworzenia norm również prawnych. Obecnie standard WCAG na poziomie AA jest obowiązkowy dla instytucji publicznych. I nie warto na nim oszczędzać i lepiej od razu zgłosić się do specjalisty, ponieważ wtyczka WCAG 2.1 WordPress nie zapewni standardu, a za brak dostępności cyfrowej przewidziano kary finansowe.

 

 

art.sponsorowany

Podziel się:

Oceń:

Komentarze (0)

Dodanie komentarza oznacza akceptację regulaminu. Treści wulgarne, obraźliwe, naruszające regulamin będą usuwane.

Wysyłając komentarz akceptujesz regulamin serwisu _______. _________ z siedzibą w ________ jest administratorem twoich danych osobowych dla celów związanych z korzystaniem z serwisu. Zgodnie z art. 24 ust. 1 pkt 3 i 4 ustawy o ochronie danych osobowych, podanie danych jest dobrowolne, Użytkownikowi przysługuje prawo dostępu do treści swoich danych i ich poprawiania.

Pozostałe